Name:           python-pipenv
Version:        2023.11.15
Release:        %autorelease
Summary:        Python Development Workflow for Humans.

# Check if the automatically generated License and its spelling is correct for Fedora
# https://docs.fedoraproject.org/en-US/packaging-guidelines/LicensingGuidelines/
License:        MIT
URL:            https://github.com/pypa/pipenv
Source:         %{pypi_source pipenv}

BuildArch:      noarch
BuildRequires:  python3-devel


# Fill in the actual package description to submit package to Fedora
%global _description %{expand:
This is package 'pipenv' generated automatically by pyp2spec.}


%description %_description

%package -n     python3-pipenv
Summary:        %{summary}

%description -n python3-pipenv %_description


%prep
%autosetup -p1 -n pipenv-%{version}


%generate_buildrequires
%pyproject_buildrequires


%build
%pyproject_wheel


%install
%pyproject_install
# For official Fedora packages, including files with '*' +auto is not allowed
# Replace it with a list of relevant Python modules/globs and list extra files in %%files
%pyproject_save_files '*' +auto


%check
%pyproject_check_import -t


%files -n python3-pipenv -f %{pyproject_files}


%changelog
%autochangelog