# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}

%global crate sspi

Name:           rust-sspi
Version:        0.15.0
Release:        %autorelease
Summary:        Rust implementation of the Security Support Provider Interface

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/sspi
Source:         %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch:          sspi-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
Patch:          sspi-fix-metadata.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
A Rust implementation of the Security Support Provider Interface (SSPI)
API.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+__install-crypto-provider-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+__install-crypto-provider-devel %{_description}

This package contains library source intended for building other packages which
use the "__install-crypto-provider" feature of the "%{crate}" crate.

%files       -n %{name}+__install-crypto-provider-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+__rustls-used-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+__rustls-used-devel %{_description}

This package contains library source intended for building other packages which
use the "__rustls-used" feature of the "%{crate}" crate.

%files       -n %{name}+__rustls-used-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+__test-data-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+__test-data-devel %{_description}

This package contains library source intended for building other packages which
use the "__test-data" feature of the "%{crate}" crate.

%files       -n %{name}+__test-data-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+aws-lc-rs-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+aws-lc-rs-devel %{_description}

This package contains library source intended for building other packages which
use the "aws-lc-rs" feature of the "%{crate}" crate.

%files       -n %{name}+aws-lc-rs-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+dns_resolver-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+dns_resolver-devel %{_description}

This package contains library source intended for building other packages which
use the "dns_resolver" feature of the "%{crate}" crate.

%files       -n %{name}+dns_resolver-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+network_client-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+network_client-devel %{_description}

This package contains library source intended for building other packages which
use the "network_client" feature of the "%{crate}" crate.

%files       -n %{name}+network_client-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+ring-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+ring-devel %{_description}

This package contains library source intended for building other packages which
use the "ring" feature of the "%{crate}" crate.

%files       -n %{name}+ring-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+scard-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+scard-devel %{_description}

This package contains library source intended for building other packages which
use the "scard" feature of the "%{crate}" crate.

%files       -n %{name}+scard-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+tsssp-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tsssp-devel %{_description}

This package contains library source intended for building other packages which
use the "tsssp" feature of the "%{crate}" crate.

%files       -n %{name}+tsssp-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog