# Generated from simple_scheduler-1.2.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name simple_scheduler

Name: rubygem-%{gem_name}
Version: 1.2.0
Release: 1%{?dist}
Summary: An enhancement for Heroku Scheduler + Sidekiq for scheduling jobs at specific times
License: MIT
URL: https://github.com/simplymadeapps/simple_scheduler
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(appraisal)
# BuildRequires: rubygem(rainbow)
# BuildRequires: rubygem(rspec-rails)
# BuildRequires: rubygem(rubocop) >= 0.66.0
# BuildRequires: rubygem(rubocop) < 0.67
# BuildRequires: rubygem(simplecov)
# BuildRequires: rubygem(simplecov-rcov)
BuildArch: noarch

%description
Simple Scheduler adds the ability to enhance Heroku
Scheduler by using Sidekiq to queue
jobs in the future. This allows for defining specific run times (Ex: Every
Sunday at 4 AM)
and running tasks more often than Heroku Scheduler's 10 minute limit.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/MIT-LICENSE
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile

%changelog
* Wed Aug 25 2021 mockbuilder - 1.2.0-1
- Initial package