# Generated from cli_helper-0.2.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name cli_helper

Name: rubygem-%{gem_name}
Version: 0.2.0
Release: 1%{?dist}
Summary: An encapsulation of an integration of slop, nenv, inifile and configatron
License: You want it?  It's yours.
URL: http://github.com/MadBomber/cli_helper
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(kick_the_tires)
# BuildRequires: rubygem(amazing_print)
# BuildRequires: rubygem(debug_me)
# BuildRequires: rubygem(timecop)
BuildArch: noarch

%description
An encapsulation of a convention I have been using
with the slop, nenv, inifile and configatron gems for quick and dirty
development of
command-line based utility programs.  Slop parses ARGV; Nenv parses ENV;
inifile parses INI; Configatron keeps it all together.  YAML and ERB
preprocessing is also available.  Ruby configuration files are also supported.
and you can specify multiple config files of mixed types at once.
.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/example
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/cli_helper.gemspec
%{gem_instdir}/tests

%changelog
* Mon Sep 13 2021 mockbuilder - 0.2.0-1
- Initial package