# Generated from dfg-airbrake-5.6.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name dfg-airbrake

Name: rubygem-%{gem_name}
Version: 5.6.2
Release: 1%{?dist}
Summary: Airbrake is an online tool that provides robust exception tracking in any of your Ruby applications
License: MIT
URL: https://airbrake.io
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(rspec-wait)
# BuildRequires: rubygem(rspec-wait) < 1
# BuildRequires: rubygem(pry)
# BuildRequires: rubygem(pry) < 1
# BuildRequires: rubygem(appraisal) >= 2
# BuildRequires: rubygem(appraisal) < 3
# BuildRequires: rubygem(rack) >= 1
# BuildRequires: rubygem(rack) < 2
# BuildRequires: rubygem(webmock) = 2.2.0
# BuildRequires: rubygem(rack-test)
# BuildRequires: rubygem(rack-test) < 1
# BuildRequires: rubygem(sidekiq) >= 4
# BuildRequires: rubygem(sidekiq) < 5
BuildArch: noarch

%description
Airbrake is an online tool that provides robust exception tracking in any of
your Ruby applications. In doing so, it allows you to easily review errors,
tie
an error to an individual piece of code, and trace the cause back to recent
changes. The Airbrake dashboard provides easy categorization, searching, and
prioritization of exceptions so that when errors occur, your team can quickly
determine the root cause.
Additionally, this gem includes integrations with such popular libraries and
frameworks as Rails, Sinatra, Resque, Sidekiq, Delayed Job, ActiveJob and many
more.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/spec

%changelog
* Mon Sep 13 2021 mockbuilder - 5.6.2-1
- Initial package