# Generated from fun_with_files-0.0.15.gem by gem2rpm -*- rpm-spec -*-
%global gem_name fun_with_files

Name: rubygem-%{gem_name}
Version: 0.0.15
Release: 1%{?dist}
Summary: A mashup of several File, FileUtils, and Dir class functions, with a peppy, fun-loving syntax
License: MIT
URL: http://github.com/darthschmoo/fun_with_files
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(fun_with_testing) >= 0.0.5
# BuildRequires: rubygem(fun_with_testing)
# BuildRequires: rubygem(fun_with_testing) < 1
BuildArch: noarch

%description
A more intuitive syntax for performing a variety of file actions. Examples:
"/".fwf_filepath.join('usr', 'bin', 'bash').touch
FunWith::Files::FilePath.home("Music").glob(:ext => "mp3", :recurse => true)
home = FunWith::Files::FilePath.home
home.touch( "Music", "CDs", "BubbleBoyTechnoRemixxxx2011",
"01-jiggypalooza.mp3" )
home.touch_dir( "Music", "CDs", "ReggaeSmackdown2008" ) do |dir|
dir.touch( "liner_notes.txt" )
dir.touch( "cover.jpg" )
dir.touch( "01-tokin_by_the_sea.mp3" )
dir.touch( "02-tourists_be_crazy_mon.mp3" )
end.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/.
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/VERSION
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/CHANGELOG.markdown
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.rdoc
%{gem_instdir}/Rakefile

%changelog
* Mon Sep 13 2021 mockbuilder - 0.0.15-1
- Initial package