# Generated from nds_api-0.1.23.gem by gem2rpm -*- rpm-spec -*-
%global gem_name nds_api

Name: rubygem-%{gem_name}
Version: 0.1.23
Release: 1%{?dist}
Summary: NDS API is a Rubygem for easy interface with the NDS API. https://developer.uatup.naccrraware.net/
License: MIT
URL: http://exygy.com
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
NDS API is a Rubygem for easy interface with the NDS API. NDS is the National
Data System for Child Care. NDS is a variety of applications and services that
facilitate the work of Child Care R&Rs. This Ruby code is an interface to the
new NDS API. This code is built and maintained by Exygy, in San Francisco. NDS
is built by Child Care Aware of America. For any questions about using this
code, please contact hello@exygy.com. For more information about NDS please
see https://usa.childcareaware.org/members-providers/data-services/.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/nds_api.gemspec

%changelog
* Tue Sep 14 2021 mockbuilder - 0.1.23-1
- Initial package