# Generated from rspreadsheet-0.5.3.gem by gem2rpm -*- rpm-spec -*-
%global gem_name rspreadsheet

Name: rubygem-%{gem_name}
Version: 0.5.3
Release: 1%{?dist}
Summary: Manipulating LibreOffice Calc (OpenDocument Spreadsheet) files from Ruby (read / create / modify)
License: GPL
URL: https://github.com/gorn/rspreadsheet
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 2.0
# BuildRequires: rubygem(pry-nav)
# BuildRequires: rubygem(coveralls) >= 0.7
BuildArch: noarch

%description
Manipulating LibreOffice Calc (OpenDocument Spreadsheet) files with Ruby. This
gem can create new, read existing files abd modify them. When modyfying files,
it tries to change as little as possible, making it as much forward compatible
as possible.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/.coveralls.yml
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/.kateproject
%exclude %{gem_instdir}/.travis.yml
%exclude %{gem_instdir}/.yardopts
%{gem_instdir}/CONFIGURATION.md
%license %{gem_instdir}/COPYING.txt
%{gem_instdir}/DEVEL_BLOG.md
%{gem_instdir}/GUIDE.md
%{gem_instdir}/Guardfile
%license %{gem_instdir}/LICENSE.md
%{gem_instdir}/TROUBLESHOOTING.md
%{gem_libdir}
%{gem_instdir}/reinstall_local_gem.sh
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/CHANGELOG.md
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/rspreadsheet.gemspec
%{gem_instdir}/spec

%changelog
* Wed Sep 15 2021 mockbuilder - 0.5.3-1
- Initial package