# Generated from automation_object-0.8.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name automation_object

Name: rubygem-%{gem_name}
Version: 0.8.4
Release: 1%{?dist}
Summary: YAML configuration based dynamic DSL framework for UI automation using Selenium or Appium drivers
License: MIT
URL: https://github.com/mikeblatter/automation_object
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.2
# BuildRequires: rubygem(rubocop) >= 0.4
# BuildRequires: rubygem(rubocop) < 1
# BuildRequires: rubygem(rubycritic) >= 3.2
# BuildRequires: rubygem(rubycritic) < 4
# BuildRequires: rubygem(yard) >= 0.9
# BuildRequires: rubygem(yard) < 1
# BuildRequires: rubygem(redcarpet) >= 3.4
# BuildRequires: rubygem(redcarpet) < 4
# BuildRequires: rubygem(pry) = 0.10
# BuildRequires: rubygem(awesome_print) >= 1.7
# BuildRequires: rubygem(awesome_print) < 2
# BuildRequires: rubygem(coveralls) >= 0.8
# BuildRequires: rubygem(coveralls) < 1
# BuildRequires: rubygem(simplecov) >= 0.1
# BuildRequires: rubygem(simplecov) < 1
# BuildRequires: rubygem(mocha) >= 1.2
# BuildRequires: rubygem(mocha) < 2
# BuildRequires: rubygem(fakefs) >= 0.11
# BuildRequires: rubygem(fakefs) < 1
# BuildRequires: rubygem(minitest) >= 5.10
# BuildRequires: rubygem(minitest) < 6
# BuildRequires: rubygem(minitest-bonus-assertions) >= 3.0
# BuildRequires: rubygem(minitest-bonus-assertions) < 4
BuildArch: noarch

%description
This gem provides a way to create a dynamic usable DSL framework representing
your website or app.
Implementing Selenium/Appium driver and YAML configurations, this API will
provide a layer in between your automation code and the driver.
By creating YAML configurations that represents your website/app, the DSL
framework in turn will reflect your configuration
and allow you to control the automation through the DSL framework.  Using this
gem can help remove tedious tasks that are often
repeated throughout code and help improve the scalability of code by mapping
UI in YAML configuration files.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}


%changelog
* Mon Aug 23 2021 mockbuilder - 0.8.4-1
- Initial package