# Generated from lwes_pure-0.1.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name lwes_pure

Name: rubygem-%{gem_name}
Version: 0.1.4
Release: 1%{?dist}
Summary: LWES - Light Weight Event System protocol implemented in pure ruby
License: MIT
URL: http://github.com/aq1018/lwes_pure
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 2.3.0
# BuildRequires: rubygem(rspec) < 2.4
# BuildRequires: rubygem(yard) >= 0.6.0
# BuildRequires: rubygem(yard) < 0.7
# BuildRequires: rubygem(jeweler) >= 1.5.2
# BuildRequires: rubygem(jeweler) < 1.6
# BuildRequires: rubygem(rcov)
# BuildRequires: rubygem(reek) >= 1.2.8
# BuildRequires: rubygem(reek) < 1.3
# BuildRequires: rubygem(roodi) >= 2.1.0
# BuildRequires: rubygem(roodi) < 2.2
BuildArch: noarch

%description
The original lwes gem is a thin wrapper around the c library, and does not
handle data types for dynamic LWES events. This gem allows users to define the
data type of attributes in an clear way, so that your LWES event listeners
will be happy. This library includes the following components.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/VERSION
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/.document
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.rdoc
%{gem_instdir}/Rakefile
%{gem_instdir}/lwes_pure.gemspec
%{gem_instdir}/spec

%changelog
* Tue Aug 24 2021 mockbuilder - 0.1.4-1
- Initial package