# Generated from poor-pokemon-cli-1.0.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name poor-pokemon-cli

Name: rubygem-%{gem_name}
Version: 1.0.1
Release: 1%{?dist}
Summary: In this simple CLI gem game, the player selects whatever pokemon they want from their pokedex to be added to their roster of 6, and then battles against an opponent, "Poorly Designed Boss"
License: MIT
URL: https://github.com/mahdiASC/cli-data-gem-assessment-v-000
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(pry)
BuildArch: noarch

%description
A simple pokemon CLI.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/poor-pokemon
%{gem_instdir}/.gitmodules
%{gem_instdir}/.learn
%license %{gem_instdir}/LICENSE.md
%{gem_instdir}/bin
%{gem_instdir}/config
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/CONTRIBUTING.md
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/poor-pokemon-cli-gem.gemspec
%{gem_instdir}/spec.md

%changelog
* Tue Aug 24 2021 mockbuilder - 1.0.1-1
- Initial package