# Generated from carthage_cache_res-0.9.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name carthage_cache_res

Name: rubygem-%{gem_name}
Version: 0.9.4
Release: 1%{?dist}
Summary: A tool that allows to cache Carthage/Build folder in Amazon S3
License: MIT
URL: https://github.com/dokim/carthage_cache_res
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec)
# BuildRequires: rubygem(pry)
# BuildRequires: rubygem(simplecov)
# BuildRequires: rubygem(codeclimate-test-reporter) >= 1.0.0
# BuildRequires: rubygem(codeclimate-test-reporter) < 1.1
# BuildRequires: rubygem(rspec_junit_formatter) >= 0.2.3
# BuildRequires: rubygem(rspec_junit_formatter) < 0.3
BuildArch: noarch

%description
CarthageCache generate a hash key based on the content of your
Cartfile.resolved and checks
if there is a cache archive (a zip file of your Carthage/Build directory)
associated to that hash.
If there is one it will download it and install it in your project avoiding
the need to run carthage bootstrap.
----------------------Thanks Mr.Blas but now we are facing dependency conflict
with Fastlane 2.144--------------------
What I want to solve: Dependency conflict with Fastlane 2.144
What I did: 
1. Changed name of this gem to "carthage_cache_res"
2. Fixed runtime dependencies: aws-sdk < 3, commander = 4.3.8
3. Changed system dependency versions: ruby > 2.6, xcode 11.x
.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/exe -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{_bindir}/carthage_cache_res
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/.ruby-version
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODEOWNERS
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_instdir}/exe
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/carthage_cache_res.gemspec

%changelog
* Mon Sep 13 2021 mockbuilder - 0.9.4-1
- Initial package