# Generated from chichilku3-14.0.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name chichilku3

Name: rubygem-%{gem_name}
Version: 14.0.4
Release: 1%{?dist}
Summary: Stick battle game
License: Unlicense
URL: https://github.com/chichilku/chichilku3
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
Simple 2d online multiplayer stick figure battle game using the gosu (SDL2
based) gem for client side graphics. The network protocol is tcp based and
only using ASCII printable characters.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/chichilku3
%{_bindir}/chichilku3-server
%{gem_instdir}/bin
%{gem_instdir}/client.json
%{gem_libdir}
%{gem_instdir}/server.json
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}


%changelog
* Mon Sep 13 2021 mockbuilder - 14.0.4-1
- Initial package