# Generated from da_funk-3.34.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name da_funk

Name: rubygem-%{gem_name}
Version: 3.34.1
Release: 1%{?dist}
Summary: MRuby Embedded System Framework
License: MIT
URL: http://github.com/cloudwalkio/da_funk
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 1.9.3
# BuildRequires: rubygem(funky-simplehttp)
# BuildRequires: rubygem(yard)
BuildArch: noarch

%description
DaFunk is a Embedded System Framework optimized for programmer happiness and
sustainable productivity. It encourages beautiful code by favoring convention
over configuration.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%exclude %{gem_instdir}/.yardopts
%license %{gem_instdir}/MIT-LICENSE
%{gem_instdir}/guides
%{gem_instdir}/imgs
%{gem_libdir}
%{gem_instdir}/out
%{gem_instdir}/utils
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%doc %{gem_instdir}/README_GUIDE.md
%doc %{gem_instdir}/RELEASE_NOTES.md
%{gem_instdir}/Rakefile
%{gem_instdir}/da_funk.gemspec
%{gem_instdir}/test

%changelog
* Mon Sep 13 2021 mockbuilder - 3.34.1-1
- Initial package