# Generated from power_trace-0.3.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name power_trace

Name: rubygem-%{gem_name}
Version: 0.3.0
Release: 1%{?dist}
Summary: power_trace provides you a more powerful backtrace
License: MIT
URL: https://github.com/st0012/power_trace
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.6.0
# BuildRequires: rubygem(pry)
# BuildRequires: rubygem(rails)
BuildArch: noarch

%description
Backtrace (Stack traces) are essential information for debugging our
applications. However, they only tell us what the program did, but don't tell
us what it had (the arguments, local variables...etc.). So it's very often
that we'd need to visit each call site, rerun the program, and try to print
out the variables. To me, It's like the Google map's navigation only tells us
the name of the roads, but not showing us the map along with them.
So I hope to solve this problem by adding some additional runtime info to the
backtrace, and save us the work to manually look them up.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/.github
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/.ruby-version
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/benchmarks
%{gem_instdir}/bin
%{gem_instdir}/images
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/examples
%{gem_instdir}/power_trace.gemspec

%changelog
* Tue Sep 14 2021 mockbuilder - 0.3.0-1
- Initial package