# Generated from rmatrix-0.1.20.gem by gem2rpm -*- rpm-spec -*-
%global gem_name rmatrix

Name: rubygem-%{gem_name}
Version: 0.1.20
Release: 1%{?dist}
Summary: Fast matrix/linear algebra library for Ruby
License: MIT
URL: https://github.com/wouterken/RMatrix
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(minitest)
# BuildRequires: rubygem(pry)
# BuildRequires: rubygem(pry-byebug)
# BuildRequires: rubygem(rbczmq)
# BuildRequires: rubygem(iruby)
BuildArch: noarch

%description
RMatrix is a lightning fast library for Ruby. It provides numerous
enhancements over the Matrix class in the standard library.
Features include the ability to calculate Matrix inverse, transpose,
determinant, minor, adjoint, cofactor_matrix, hadamard product and other
elementwise operations, slicing, masking and more.
RMatrix makes use of backing instances of NArray to allow for great
performance.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%{gem_instdir}/rmatrix.todo
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/examples
%{gem_instdir}/rmatrix.gemspec

%changelog
* Tue Sep 14 2021 mockbuilder - 0.1.20-1
- Initial package