# Generated from sinatra-cors-1.2.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name sinatra-cors

Name: rubygem-%{gem_name}
Version: 1.2.0
Release: 1%{?dist}
Summary: CORS support for Sinatra applications
License: MIT
URL: https://github.com/jdesrosiers/sinatra-cors
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
This Sinatra plugin supports the full CORS spec including automatic support
for CORS preflight (OPTIONS) requests.  It uses CORS security best practices. 
The plugin logs to the default logger to guide you in setting things up
properly.  It will tell you why a CORS request failed and tell you how to fix
it.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}


%changelog
* Wed Sep 15 2021 mockbuilder - 1.2.0-1
- Initial package