# Generated from xmigra-1.7.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name xmigra

Name: rubygem-%{gem_name}
Version: 1.7.4
Release: 1%{?dist}
Summary: Toolkit for managing database schema evolution with version control
License: CC-BY-SA 4.0 Itnl.
URL: https://github.com/rtweeks/xmigra
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
XMigra is a suite of tools for managing database schema evolution with
version controlled files.  All database manipulations are written in
SQL (specific to the target database).  Works with Git or Subversion.
Currently supports Microsoft SQL Server and PostgreSQL.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/xmigra
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/LICENSE.html
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/test
%{gem_instdir}/xmigra.gemspec

%changelog
* Thu Sep 16 2021 mockbuilder - 1.7.4-1
- Initial package