# Generated from http-token-auth-0.1.3.gem by gem2rpm -*- rpm-spec -*-
%global gem_name http-token-auth

Name: rubygem-%{gem_name}
Version: 0.1.3
Release: 1%{?dist}
Summary: Ruby gem to handle the HTTP Token Access Authentication draft specification, for securing HTTP-based service and microservice architectures using token credentials
License: MIT
URL: https://github.com/felipead/http-token-auth
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.1.0
BuildArch: noarch

%description
Ruby gem to handle the HTTP Token Access Authentication draft specification,
for securing HTTP-based service and microservice architectures using token
credentials. It supports both parsing and building a HTTP "Authentication"
request header and a "WWW-Authenticate" response header using the token
scheme.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/LICENSE.txt
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/http-token-auth.gemspec

%changelog
* Tue Aug 24 2021 mockbuilder - 0.1.3-1
- Initial package