# Generated from popular_deals-1.1.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name popular_deals

Name: rubygem-%{gem_name}
Version: 1.1.1
Release: 1%{?dist}
Summary: It displays popular deals of the day from https://slickdeals.net/deals/ with popular-deals command
License: MIT
URL: https://github.com/HimaChitalia/popular_deals
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
This CLI gem displays 5 lists of top 100 deals with ratings and prices from
slickdeals.net/deals. Just use 'popular-deals' command.
You can also view more details by typing respective deal number.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/console
%{_bindir}/popular-deals
%{_bindir}/setup
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/NOTES.md
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/popular_deals.gemspec
%{gem_instdir}/spec.md

%changelog
* Tue Aug 24 2021 mockbuilder - 1.1.1-1
- Initial package