# Generated from apicasso-0.7.3.gem by gem2rpm -*- rpm-spec -*-
%global gem_name apicasso

Name: rubygem-%{gem_name}
Version: 0.7.3
Release: 1%{?dist}
Summary: An abstract API design as a mountable engine
License: MIT
URL: https://github.com/ErvalhouS/APIcasso
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(capybara) >= 3.15.0
# BuildRequires: rubygem(capybara) < 3.16
# BuildRequires: rubygem(database_cleaner)
# BuildRequires: rubygem(factory_bot_rails)
# BuildRequires: rubygem(faker)
# BuildRequires: rubygem(pg)
# BuildRequires: rubygem(rspec-rails)
BuildArch: noarch

%description
Create APIs in a fast and dynamic way, without the need to develop everything
from scratch. You just need to create your models and let APIcasso do the rest
for you. It is the perfect candidate to make your project development go
faster or for legacy Rails projects that do not have an API. If you think it
through, JSON API development can get boring and time consuming. Every time
you use almost the same route structure, pointing to the same controller
actions, with the same ordering, filtering and pagination features. APIcasso
is intended to be used to speed-up development, acting as a full-fledged CRUD
JSON API into all your models. It is a route-based abstraction that lets you
create, read, list, update or delete any ActiveRecord object in your
application. This makes it possible to make CRUD-only applications just by
creating functional Rails' models. Access to your application's resources is
managed by a .scope JSON object per API key. It uses that permission scope to
restrict and extend access.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/app
%{gem_instdir}/config
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/spec

%changelog
* Sun Sep 12 2021 mockbuilder - 0.7.3-1
- Initial package