# Generated from array-stack-1.2.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name array-stack

Name: rubygem-%{gem_name}
Version: 1.2.0
Release: 1%{?dist}
Summary: An array-based stack data structure class
License: MIT
URL: https://github.com/scientist8202/array-stack
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(minitest) >= 5.0
# BuildRequires: rubygem(minitest) < 6
BuildArch: noarch

%description
The stack operations work for
non-atomic objects. The class consists seven public methods, one private
method, and one protected method. Initialization includes two instance
variables: `@array` and `@size`. The public methods are the `size()` method,
the `initialize(value = nil)` method, the `empty?()` method, the `push()`
method, the `pop(amount = 1)` method, the `top()` method, and the
`array=(array_stack)` method. The `size=(value)` method is private, and the
`array()` method was `protected`. The `initialize(value = nil` method, the
`push()` method, the `top()` method, the `array=(array_stack)` method, and
the `array()` method deeply copies either the arguments or the return objects.
The class was basically tested. .


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/.idea
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/array-stack.gemspec

%changelog
* Sun Sep 12 2021 mockbuilder - 1.2.0-1
- Initial package