# Generated from dbi-dbrc-1.7.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name dbi-dbrc

Name: rubygem-%{gem_name}
Version: 1.7.0
Release: 1%{?dist}
Summary: A simple way to avoid hard-coding passwords with DBI
License: Apache-2.0
URL: https://github.com/djberg96/dbi-dbrc
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3.9
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(fakefs) >= 1.3
# BuildRequires: rubygem(fakefs) < 2
BuildArch: noarch

%description
The dbi-dbrc library provides an interface for storing database
connection information, including passwords, in a locally secure
file only accessible by you, or root. This allows you to avoid
hard coding login and password information in your programs
that require such information.
This library can also be used to store login and password information
for logins on remote hosts, not just databases.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{gem_instdir}/CHANGES.md
%{gem_instdir}/MANIFEST.md
%{gem_instdir}/certs
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/dbi-dbrc.gemspec
%{gem_instdir}/examples
%{gem_instdir}/spec

%changelog
* Mon Sep 13 2021 mockbuilder - 1.7.0-1
- Initial package