# Generated from enumify-1.0.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name enumify

Name: rubygem-%{gem_name}
Version: 1.0.0
Release: 1%{?dist}
Summary: enumify adds an enum command to all ActiveRecord models which enables you to work with string attributes as if they were enums
License: MIT
URL: http://github.com/yonbergman/enumify
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec)
# BuildRequires: rubygem(activerecord) >= 3.0
# BuildRequires: rubygem(appraisal) >= 0.3.8
BuildArch: noarch

%description
Enumify lets you add an enum command to ActiveRecord models
There are four things that the enumify gems adds to your model
Validation - The enumify adds a validation to make sure that the field only
receives accepted values
Super Cool Methods - adds ? and ! functions for each enum value (canceled? -
is it canceled, canceled! - change the state to canceled)
Callback support - you can add a x_callback method which will be called each
time the status changes
Scopes - you can easily query for values of the enum.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/Appraisals
%{gem_instdir}/Guardfile
%license %{gem_instdir}/LICENSE
%{gem_instdir}/gemfiles
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%doc %{gem_instdir}/CHANGELOG.md
%{gem_instdir}/Gemfile
%{gem_instdir}/Rakefile
%doc %{gem_instdir}/Readme.md
%{gem_instdir}/enumify.gemspec
%{gem_instdir}/spec

%changelog
* Mon Sep 13 2021 mockbuilder - 1.0.0-1
- Initial package