# Generated from pwss-0.7.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name pwss

Name: rubygem-%{gem_name}
Version: 0.7.0
Release: 1%{?dist}
Summary: A password manager in the spirit of pass and pws
License: MIT
URL: http://www.github.com/avillafiorita/pwss
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(minitest)
BuildArch: noarch

%description
PWSS is a command-line password manager, in the spirit of pws
Distinguishing features:
- pwss manages different password files
- a password file can store multiple entries
- entries can be of different types (e.g., Entry, CreditCard, BankAccount)
- each type stores specific information (e.g., card_number for CreditCards)
- a password file can be encrypted or stored in plain text (if you wish to do
so)
- decrypt and encrypt commands allow one to edit password files with a text
editor
- clipboard integration
- multi-platform.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/exe -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%{_bindir}/pwss
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_instdir}/exe
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/ChangeLog.md
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/pwss.gemspec

%changelog
* Tue Sep 14 2021 mockbuilder - 0.7.0-1
- Initial package