# Generated from sequel-audited-0.2.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name sequel-audited

Name: rubygem-%{gem_name}
Version: 0.2.0
Release: 1%{?dist}
Summary: A Sequel plugin that logs changes made to an audited model, including who created, updated and destroyed the record, and what was changed and when the change was made
License: MIT
URL: https://github.com/kematzy/sequel-audited
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(minitest) >= 5.7.0
# BuildRequires: rubygem(minitest-rg)
# BuildRequires: rubygem(minitest-assert_errors)
# BuildRequires: rubygem(minitest-hooks)
# BuildRequires: rubygem(minitest-sequel) >= 0.3.2
# BuildRequires: rubygem(pg)
# BuildRequires: rubygem(simplecov)
# BuildRequires: rubygem(rubocop)
# BuildRequires: rubygem(dotenv)
BuildArch: noarch

%description
A Sequel plugin that logs changes made to an audited model, including who
created, updated and destroyed the record, and what was changed and when the
change was made. This plugin provides model auditing (a.k.a: record
versioning) for DB scenarios when DB triggers are not possible. (ie: on a web
app on Heroku).


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/CODE_OF_CONDUCT.md
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/TODOs.md
%{gem_instdir}/bin
%{gem_instdir}/env.test.sample
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/sequel-audited.gemspec

%changelog
* Wed Sep 15 2021 mockbuilder - 0.2.0-1
- Initial package