# Generated from shotstack-0.1.8.gem by gem2rpm -*- rpm-spec -*-
%global gem_name shotstack
Name: rubygem-%{gem_name}
Version: 0.1.8
Release: 1%{?dist}
Summary: Shotstack SDK Ruby Gem
License: MIT
URL: https://shotstack.io
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.4
# BuildRequires: rubygem(rspec) >= 3.6
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(rspec) >= 3.6.0
BuildArch: noarch
%description
Shotstack is a video, image and audio editing service that allows for the
automated generation of videos, images and audio using JSON and a RESTful API.
You arrange and configure an edit and POST it to the API which will render
your media and provide a file location when complete. For more details visit
[shotstack.io](https://shotstack.io) or checkout our [getting
started](https://shotstack.gitbook.io/docs/guides/getting-started)
documentation. There are two main API's, one for editing and generating assets
(Edit API) and one for managing hosted assets (Serve API). The Edit API base
URL is: https://api.shotstack.io/{version} The Serve API base URL is:
https://api.shotstack.io/serve/{version}.
%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch
%description doc
Documentation for %{name}.
%prep
%setup -q -n %{gem_name}-%{version}
%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec
# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install
%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
%{buildroot}%{gem_dir}/
%check
pushd .%{gem_instdir}
# rspec spec
popd
%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}
%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%{gem_instdir}/shotstack.gemspec
%changelog
* Wed Sep 15 2021 mockbuilder - 0.1.8-1
- Initial package