# Generated from sinatra-rroute-0.1.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name sinatra-rroute

Name: rubygem-%{gem_name}
Version: 0.1.0
Release: 1%{?dist}
Summary: Rails-style routes with names, namespaces and `path' helper
License: MIT
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch

%description
Sinatra-rraoute provides `gget'/`ppost'/`ddelete'/... methods which work
just like Sinatra's built-in `get'/`post'/`delete'/... methods, but which
map named routes to functions so that they can be referenced in redirects
etc.
The `path' helper will return a route for a certain route name and the
given values for this route and comes in handy in both, the
controller/model component of the application, and the view where you can
use it to render links, assets URLs, AJAX calls...
The nestable `nnamespace' method is useful for API versioning and does not
interfere with other namespace extensions for Sinatra.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%license %{gem_instdir}/LICENSE.txt
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/rroute.gemspec
%{gem_instdir}/spec

%changelog
* Wed Sep 15 2021 mockbuilder - 0.1.0-1
- Initial package