# Generated from testcentricity-2.4.3.gem by gem2rpm -*- rpm-spec -*-
%global gem_name testcentricity

Name: rubygem-%{gem_name}
Version: 2.4.3
Release: 1%{?dist}
Summary: A Page Object and Data Object Model Framework for desktop/mobile web and native mobile app testing
License: BSD-3-Clause-Clear
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.3.0
BuildArch: noarch

%description
The TestCentricityâ„¢ core generic framework for desktop/mobile web and
native mobile app testing implements a Page Object Model DSL
for use with Cucumber, Capybara, Appium, and Selenium-Webdriver. The
TestCentricityâ„¢ gem supports running automated tests
against locally hosted desktop browsers (Firefox, Chrome, Safari, or IE),
locally hosted emulated mobile browsers (iOS,
Android, Windows Phone, Blackberry, Kindle Fire) running within a locally
hosted instance of Chrome, a "headless" browser (using
Poltergeist and PhantomJS), mobile Safari browsers on iOS device simulators or
physical iOS devices  (using Appium and XCode on
OS X), mobile Chrome or Android browsers on Android Studio virtual device
emulators (using Appium and Android Studio on OS X),
or cloud hosted desktop or mobile web browsers (using the BrowserStack, Sauce
Labs, CrossBrowserTesting, or TestingBot services).


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/console
%{_bindir}/setup
%exclude %{gem_instdir}/.gitignore
%{gem_instdir}/.ruby-gemset
%{gem_instdir}/.ruby-version
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/bin
%{gem_libdir}
%{gem_instdir}/my_templates
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%exclude %{gem_instdir}/.rspec
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/spec
%{gem_instdir}/testcentricity.gemspec

%changelog
* Thu Sep 16 2021 mockbuilder - 2.4.3-1
- Initial package