# Generated from thingfish-0.8.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name thingfish

Name: rubygem-%{gem_name}
Version: 0.8.0
Release: 1%{?dist}
Summary: Thingfish is a extensible, web-based digital asset manager
License: BSD-3-Clause
URL: https://thing.fish
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rake-deveiate) >= 0.10
# BuildRequires: rubygem(rake-deveiate) < 1
# BuildRequires: rubygem(rdoc-generator-fivefish) >= 0.4
# BuildRequires: rubygem(rdoc-generator-fivefish) < 1
# BuildRequires: rubygem(simplecov) >= 0.18
# BuildRequires: rubygem(simplecov) < 1
BuildArch: noarch

%description
Thingfish is a extensible, web-based digital asset manager. It can be used to
store chunks of data on the network in an application-independent way, link
the chunks together with metadata, and then search for the chunk you need
later and fetch it, all through a REST API.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/thingfish
%{gem_instdir}/.simplecov
%license %{gem_instdir}/LICENSE
%{gem_instdir}/bin
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/History.md
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/spec

%changelog
* Thu Sep 16 2021 mockbuilder - 0.8.0-1
- Initial package