# Generated from basechip-0.0.4.gem by gem2rpm -*- rpm-spec -*-
%global gem_name basechip

Name: rubygem-%{gem_name}
Version: 0.0.4
Release: 1%{?dist}
Summary: An open source simulation environment in Ruby
License: GPLv3
URL: http://basechip.com
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(yard)
# BuildRequires: rubygem(jeweler) >= 1.6.4
# BuildRequires: rubygem(jeweler) < 1.7
# BuildRequires: rubygem(rcov)
# BuildRequires: rubygem(turn)
BuildArch: noarch

%description
Define your project in terms of blocks, configurations, tests, and modes. 
Install or Create recipes and/or plugins to define actions, compute clusters,
and tools for simulation, synthesis, or anything else.  Run your actions,
test_lists, or tests in parallel, with dependencies, on a cluster, or locally.
Share your recipes and plugins with people down the hall and around the world.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/


mkdir -p %{buildroot}%{_bindir}
cp -a .%{_bindir}/* \
        %{buildroot}%{_bindir}/

find %{buildroot}%{gem_instdir}/bin -type f | xargs chmod a+x

%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%{_bindir}/basechip
%{gem_instdir}/.
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/VERSION
%{gem_instdir}/bin
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/.document
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.rdoc

%changelog
* Mon Apr 18 2022 mockbuilder - 0.0.4-1
- Initial package