# Generated from dbt-1.2.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name dbt
Name: rubygem-%{gem_name}
Version: 1.2.0
Release: 1%{?dist}
Summary: Keep your Rakefile and debugger_cmds files short and consistent
License: BSD
URL: https://github.com/colinta/dbt
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
BuildArch: noarch
%description
== DBT (Dependencies and deBugging Tool)
DBT is a tool that helps declare dependencies (+app.files_dependencies+) and
assists with debugging in a RubyMotion project. It looks for 'break',
'requires', and 'provides' commands (it does a *teensy* bit of code analyzing
to
provide some defaults) to make your RubyMotion +Rakefile+ and +debugger_cmds+
files short and consistent.
To use, include this gem, and add +DBT.analyze(app)+ to your +Rakefile+ in the
Motion::Project::App.setup block. In your source code you can add
DBT
commands and those will be translated into directives for
+app.files_dependencies+ and +debugger_cmds+.
Run +rake+ or rake debug=1, and off you go!
%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch
%description doc
Documentation for %{name}.
%prep
%setup -q -n %{gem_name}-%{version}
%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec
# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install
%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
%{buildroot}%{gem_dir}/
%check
pushd .%{gem_instdir}
# Run the test suite.
popd
%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}
%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md
%changelog
* Mon Apr 18 2022 mockbuilder - 1.2.0-1
- Initial package