# Generated from dialable-1.0.2.gem by gem2rpm -*- rpm-spec -*-
%global gem_name dialable

Name: rubygem-%{gem_name}
Version: 1.0.2
Release: 1%{?dist}
Summary: Provides parsing and output of phone numbers according to NANPA standards
License: MIT and LGPL-2
URL: http://github.com/chorn/dialable
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 1.9.0
# BuildRequires: rubygem(codeclimate-test-reporter) >= 0.4
# BuildRequires: rubygem(codeclimate-test-reporter) < 1
# BuildRequires: rubygem(guard) >= 2.12
# BuildRequires: rubygem(guard) < 3
# BuildRequires: rubygem(guard-bundler) >= 2.1
# BuildRequires: rubygem(guard-bundler) < 3
# BuildRequires: rubygem(guard-rspec) >= 4.5
# BuildRequires: rubygem(guard-rspec) < 5
# BuildRequires: rubygem(rspec) >= 3.3
# BuildRequires: rubygem(rspec) < 4
BuildArch: noarch

%description
A gem that provides parsing and output of phone numbers according to NANPA
(North American Numbering Plan Administration) standards.  If possible, time
zones are populated by abbreviation as well as offset relative to the local
timezone.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%exclude %{gem_instdir}/.gitignore
%exclude %{gem_instdir}/.travis.yml
%{gem_instdir}/Guardfile
%license %{gem_instdir}/LICENSE
%{gem_instdir}/certs
%{gem_instdir}/checksums
%{gem_instdir}/data
%{gem_libdir}
%{gem_instdir}/support
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/dialable.gemspec
%{gem_instdir}/spec

%changelog
* Mon Apr 18 2022 mockbuilder - 1.0.2-1
- Initial package