# Generated from evanescent-1.1.0.gem by gem2rpm -*- rpm-spec -*-
%global gem_name evanescent

Name: rubygem-%{gem_name}
Version: 1.1.0
Release: 1%{?dist}
Summary: IO like object that allows logging rotation, compression and purging
License: GPLv3
URL: https://github.com/fornellas/evanescent
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(rspec) >= 3.3
# BuildRequires: rubygem(rspec) < 4
# BuildRequires: rubygem(guard-rspec) >= 4.6
# BuildRequires: rubygem(guard-rspec) < 5
# BuildRequires: rubygem(guard-rspec) >= 4.6.4
# BuildRequires: rubygem(guard-rspec) < 4.7
# BuildRequires: rubygem(simplecov) >= 0.10
# BuildRequires: rubygem(simplecov) < 1
# BuildRequires: rubygem(timecop) >= 0.8
# BuildRequires: rubygem(timecop) < 1
BuildArch: noarch

%description
This gem provides an IO like object, that can be used with any logging class
(such as Ruby's native Logger). This object will save its input to a file, and
allows: rotation by time / date, compression of old files and removal of old
compressed files. Its purpuse is to supplement logging classes, allowing
everything related to logging management, to be done within Ruby, without
relying on external tools (such as logrotate).


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# rspec spec
popd

%files
%dir %{gem_instdir}
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/README.md

%changelog
* Tue Apr 19 2022 mockbuilder - 1.1.0-1
- Initial package