# Generated from native-query-0.9.6.gem by gem2rpm -*- rpm-spec -*-
%global gem_name native-query

Name: rubygem-%{gem_name}
Version: 0.9.6
Release: 1%{?dist}
Summary: Cool way how to speak with database server. It's ellegant DSL; the SQL query helper which works by similar way as Arel or another ORM selecting logic. But it's derived from Dibi database layer in its ideas, so it's much more simple and (of sure) much more KISS, readable and straightforward
License: MIT
URL: http://github.com/martinkozak/native-query
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby
# BuildRequires: rubygem(jeweler2) >= 2.0.0
BuildArch: noarch

%description
Cool way how to speak with database server. It's ellegant DSL; the SQL query
helper which works by similar way as Arel or another ORM selecting logic. But
it's derived from Dibi database layer in its ideas, so it's much more simple
and (of sure) much more KISS, readable and straightforward.


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# Run the test suite.
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/LICENSE.txt
%{gem_instdir}/VERSION
%{gem_libdir}
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%doc %{gem_instdir}/.document
%{gem_instdir}/Gemfile
%{gem_instdir}/Gemfile.lock
%doc %{gem_instdir}/README.md
%{gem_instdir}/Rakefile
%{gem_instdir}/native-query.gemspec

%changelog
* Tue Apr 19 2022 mockbuilder - 0.9.6-1
- Initial package