# Generated from ruby-vnu-0.0.1.gem by gem2rpm -*- rpm-spec -*-
%global gem_name ruby-vnu

Name: rubygem-%{gem_name}
Version: 0.0.1
Release: 1%{?dist}
Summary: Ruby wrapper for Nu HTML validator
License: MIT
URL: http://github.com/spk/ruby-vnu
Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
BuildRequires: ruby(release)
BuildRequires: rubygems-devel
BuildRequires: ruby >= 2.0.0
# BuildRequires: rubygem(minitest) >= 5.4
# BuildRequires: rubygem(minitest) < 6
# BuildRequires: rubygem(pry) >= 0.9
# BuildRequires: rubygem(pry) < 1
BuildArch: noarch

%description
Ruby wrapper for Nu HTML validator (https://validator.github.io/validator/).


%package doc
Summary: Documentation for %{name}
Requires: %{name} = %{version}-%{release}
BuildArch: noarch

%description doc
Documentation for %{name}.

%prep
%setup -q -n %{gem_name}-%{version}

%build
# Create the gem as gem install only works on a gem file
gem build ../%{gem_name}-%{version}.gemspec

# %%gem_install compiles any C extensions and installs the gem into ./%%gem_dir
# by default, so that we can move it into the buildroot in %%install
%gem_install

%install
mkdir -p %{buildroot}%{gem_dir}
cp -a .%{gem_dir}/* \
        %{buildroot}%{gem_dir}/



%check
pushd .%{gem_instdir}
# ruby -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
popd

%files
%dir %{gem_instdir}
%license %{gem_instdir}/LICENSE
%{gem_libdir}
%{gem_instdir}/vnu.jar
%exclude %{gem_cache}
%{gem_spec}

%files doc
%doc %{gem_docdir}
%{gem_instdir}/Rakefile
%{gem_instdir}/spec

%changelog
* Wed Apr 20 2022 mockbuilder - 0.0.1-1
- Initial package