## START: Set by rpmautospec
## (rpmautospec version 0.3.8)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 25
# * missing dependencies (too many to list)
%bcond_with check
%global debug_package %{nil}

%global crate opendal

Name:           rust-opendal
Version:        0.40.0
Release:        %autorelease
Summary:        OpenDAL: Access data freely, painlessly, and efficiently

License:        Apache-2.0
URL:            https://crates.io/crates/opendal
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
Patch:          opendal-fix-metadata.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
OpenDAL: Access data freely, painlessly, and efficiently.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
# FIXME: no license files detected
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/CONTRIBUTING.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+docs-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+docs-devel %{_description}

This package contains library source intended for building other packages which
use the "docs" feature of the "%{crate}" crate.

%files       -n %{name}+docs-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+native-tls-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+native-tls-devel %{_description}

This package contains library source intended for building other packages which
use the "native-tls" feature of the "%{crate}" crate.

%files       -n %{name}+native-tls-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+rustls-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+rustls-devel %{_description}

This package contains library source intended for building other packages which
use the "rustls" feature of the "%{crate}" crate.

%files       -n %{name}+rustls-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-azblob-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-azblob-devel %{_description}

This package contains library source intended for building other packages which
use the "services-azblob" feature of the "%{crate}" crate.

%files       -n %{name}+services-azblob-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-azdls-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-azdls-devel %{_description}

This package contains library source intended for building other packages which
use the "services-azdls" feature of the "%{crate}" crate.

%files       -n %{name}+services-azdls-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-cos-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-cos-devel %{_description}

This package contains library source intended for building other packages which
use the "services-cos" feature of the "%{crate}" crate.

%files       -n %{name}+services-cos-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-fs-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-fs-devel %{_description}

This package contains library source intended for building other packages which
use the "services-fs" feature of the "%{crate}" crate.

%files       -n %{name}+services-fs-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-gcs-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-gcs-devel %{_description}

This package contains library source intended for building other packages which
use the "services-gcs" feature of the "%{crate}" crate.

%files       -n %{name}+services-gcs-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-ghac-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-ghac-devel %{_description}

This package contains library source intended for building other packages which
use the "services-ghac" feature of the "%{crate}" crate.

%files       -n %{name}+services-ghac-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-http-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-http-devel %{_description}

This package contains library source intended for building other packages which
use the "services-http" feature of the "%{crate}" crate.

%files       -n %{name}+services-http-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-ipmfs-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-ipmfs-devel %{_description}

This package contains library source intended for building other packages which
use the "services-ipmfs" feature of the "%{crate}" crate.

%files       -n %{name}+services-ipmfs-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-memcached-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-memcached-devel %{_description}

This package contains library source intended for building other packages which
use the "services-memcached" feature of the "%{crate}" crate.

%files       -n %{name}+services-memcached-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-memory-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-memory-devel %{_description}

This package contains library source intended for building other packages which
use the "services-memory" feature of the "%{crate}" crate.

%files       -n %{name}+services-memory-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-obs-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-obs-devel %{_description}

This package contains library source intended for building other packages which
use the "services-obs" feature of the "%{crate}" crate.

%files       -n %{name}+services-obs-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-oss-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-oss-devel %{_description}

This package contains library source intended for building other packages which
use the "services-oss" feature of the "%{crate}" crate.

%files       -n %{name}+services-oss-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-redis-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-redis-devel %{_description}

This package contains library source intended for building other packages which
use the "services-redis" feature of the "%{crate}" crate.

%files       -n %{name}+services-redis-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-redis-native-tls-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-redis-native-tls-devel %{_description}

This package contains library source intended for building other packages which
use the "services-redis-native-tls" feature of the "%{crate}" crate.

%files       -n %{name}+services-redis-native-tls-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-redis-rustls-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-redis-rustls-devel %{_description}

This package contains library source intended for building other packages which
use the "services-redis-rustls" feature of the "%{crate}" crate.

%files       -n %{name}+services-redis-rustls-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-s3-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-s3-devel %{_description}

This package contains library source intended for building other packages which
use the "services-s3" feature of the "%{crate}" crate.

%files       -n %{name}+services-s3-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-webdav-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-webdav-devel %{_description}

This package contains library source intended for building other packages which
use the "services-webdav" feature of the "%{crate}" crate.

%files       -n %{name}+services-webdav-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+services-webhdfs-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+services-webhdfs-devel %{_description}

This package contains library source intended for building other packages which
use the "services-webhdfs" feature of the "%{crate}" crate.

%files       -n %{name}+services-webhdfs-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+trust-dns-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+trust-dns-devel %{_description}

This package contains library source intended for building other packages which
use the "trust-dns" feature of the "%{crate}" crate.

%files       -n %{name}+trust-dns-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
## START: Generated by rpmautospec
* Sat Dec 23 2023 Aleksei Bavshin <alebastr@fedoraproject.org> - 0.40.0-1
- Update to 0.40.0

* Sun Mar 26 2023 Aleksei Bavshin <alebastr@fedoraproject.org> - 0.27.2-1
- Initial package
## END: Generated by rpmautospec