## START: Set by rpmautospec
## (rpmautospec version 0.3.8)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}

%global crate multipart
%global __cargo_is_bin() false

Name:           rust-multipart
Version:        0.18.0
Release:        %autorelease
Summary:        Backend-agnostic extension for HTTP libraries that provides support for POST multipart/form-data requests on both client and server

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/multipart
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
Patch:          multipart-fix-metadata.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
A backend-agnostic extension for HTTP libraries that provides support
for POST multipart/form-data requests on both client and server.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/lorem_ipsum.txt
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+buf_redux-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+buf_redux-devel %{_description}

This package contains library source intended for building other packages which
use the "buf_redux" feature of the "%{crate}" crate.

%files       -n %{name}+buf_redux-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+client-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+client-devel %{_description}

This package contains library source intended for building other packages which
use the "client" feature of the "%{crate}" crate.

%files       -n %{name}+client-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+clippy-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+clippy-devel %{_description}

This package contains library source intended for building other packages which
use the "clippy" feature of the "%{crate}" crate.

%files       -n %{name}+clippy-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+httparse-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+httparse-devel %{_description}

This package contains library source intended for building other packages which
use the "httparse" feature of the "%{crate}" crate.

%files       -n %{name}+httparse-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+lazy_static-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+lazy_static-devel %{_description}

This package contains library source intended for building other packages which
use the "lazy_static" feature of the "%{crate}" crate.

%files       -n %{name}+lazy_static-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+mock-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+mock-devel %{_description}

This package contains library source intended for building other packages which
use the "mock" feature of the "%{crate}" crate.

%files       -n %{name}+mock-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+quick-error-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+quick-error-devel %{_description}

This package contains library source intended for building other packages which
use the "quick-error" feature of the "%{crate}" crate.

%files       -n %{name}+quick-error-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+rocket-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+rocket-devel %{_description}

This package contains library source intended for building other packages which
use the "rocket" feature of the "%{crate}" crate.

%files       -n %{name}+rocket-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+safemem-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+safemem-devel %{_description}

This package contains library source intended for building other packages which
use the "safemem" feature of the "%{crate}" crate.

%files       -n %{name}+safemem-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+server-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+server-devel %{_description}

This package contains library source intended for building other packages which
use the "server" feature of the "%{crate}" crate.

%files       -n %{name}+server-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+tiny_http-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tiny_http-devel %{_description}

This package contains library source intended for building other packages which
use the "tiny_http" feature of the "%{crate}" crate.

%files       -n %{name}+tiny_http-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+twoway-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+twoway-devel %{_description}

This package contains library source intended for building other packages which
use the "twoway" feature of the "%{crate}" crate.

%files       -n %{name}+twoway-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
## START: Generated by rpmautospec
* Sat Dec 23 2023 Aleksei Bavshin <alebastr@fedoraproject.org> - 0.18.0-1
- Initial package
## END: Generated by rpmautospec