## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 1;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Generated by go2rpm 1.15.0.post0
%bcond check 1

# https://github.com/FiloSottile/mkcert
%global goipath         github.com/FiloSottile/mkcert
Version:                1.4.4

%gometa -L -f

%global common_description %{expand:
A simple zero-config tool to make locally trusted development certificates with
any names you'd like.}

Name:           mkcert
Release:        %autorelease
Summary:        A simple zero-config tool to make locally trusted development certificates with any names you'd like

# Generated by go-vendor-tools
License:        BSD-2-Clause AND BSD-3-Clause
URL:            %{gourl}
Source0:        %{gosource}
# Generated by go-vendor-tools
Source1:        %{archivename}-vendor.tar.bz2
Source2:        go-vendor-tools.toml

BuildRequires:  go-vendor-tools

Requires:       nss-tools

%description %{common_description}

%prep
%goprep -A
%setup -q -T -D -a1 %{forgesetupargs}
%autopatch -p1

%generate_buildrequires
%go_vendor_license_buildrequires -c %{S:2}

%build
%gobuild -o %{gobuilddir}/bin/mkcert %{goipath}

%install
%go_vendor_license_install -c %{S:2}
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/

%check
%go_vendor_license_check -c %{S:2}
%if %{with check}
%gocheck
%endif

%files -f %{go_vendor_license_filelist}
%license vendor/modules.txt
%doc AUTHORS README.md
%{_bindir}/mkcert


%changelog
## START: Generated by rpmautospec
* Sat Dec 28 2024 John Doe <packager@example.com> - 1.4.4-1
- Uncommitted changes
## END: Generated by rpmautospec