## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
    release_number = 6;
    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
    print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec

# Created by pyp2rpm-3.3.5
%global pypi_name hypothesmith

%global common_description %{expand:
Hypothesis strategies for generating Python programs, something like CSmith.}

# Disable tests on EPEL as it requires black which won't be available in
# EPEL, see rhbz#2319803 and rhbz#2332437.
%bcond tests %{undefined rhel}

Name:           python-%{pypi_name}
Version:        0.3.3
Release:        %autorelease
Summary:        Hypothesis strategies for generating Python programs

License:        MPL-2.0
URL:            https://github.com/Zac-HD/hypothesmith
Source0:        %{pypi_source}
BuildArch:      noarch

BuildRequires:  python3-devel

%description
%{common_description}


%package -n     python3-%{pypi_name}
Summary:        %{summary}

%description -n python3-%{pypi_name}
%{common_description}


%prep
%autosetup -n %{pypi_name}-%{version}
# Remove bundled egg-info
# rm -rf %{pypi_name}.egg-info
# Tox configuration is passing unsupported arguments to pytest
# rm tox.ini

%generate_buildrequires
%pyproject_buildrequires %{?with_tests: -r deps/test.in}


%build
%pyproject_wheel


%install
%pyproject_install

%pyproject_save_files %{pypi_name}


%if %{with tests}
%check
%pytest
%endif


%files -n python3-%{pypi_name} -f %{pyproject_files}
%license LICENSE
%doc README.md CHANGELOG.md


%changelog
## START: Generated by rpmautospec
* Tue Mar 04 2025 Romain Geissler <romain.geissler@amadeus.com> - 0.3.3-6
- Disable tests in EPEL.

* Sat Jan 18 2025 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.3-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_42_Mass_Rebuild

* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.3-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild

* Sun Jun 09 2024 Python Maint <python-maint@redhat.com> - 0.3.3-3
- Rebuilt for Python 3.13

* Fri Jun 07 2024 Python Maint <python-maint@redhat.com> - 0.3.3-2
- Bootstrap for Python 3.13

* Sat Feb 24 2024 Michel Lind <salimma@fedoraproject.org> - 0.3.3-1
- Update to 0.3.3

* Sun Jan 28 2024 Michel Lind <salimma@fedoraproject.org> - 0.3.2-1
- Update to 0.3.2
- Convert to SPDX license identifier

* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild

* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild

* Thu Jul 13 2023 Python Maint <python-maint@redhat.com> - 0.2.0-8
- Rebuilt for Python 3.12

* Wed Jun 28 2023 Python Maint <python-maint@redhat.com> - 0.2.0-7
- Bootstrap for Python 3.12

* Fri Apr 21 2023 Tomáš Hrnčiar <thrnciar@redhat.com> - 0.2.0-6
- Add bcond to disable tests

* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild

* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild

* Mon Jun 20 2022 Python Maint <python-maint@redhat.com> - 0.2.0-3
- Rebuilt for Python 3.11

* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild

* Sat Jan 15 2022 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.2.0-1
- Update to 0.2.0 Use automatic BRs

* Sun Nov 07 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 0.1.9-1
- Update to 0.1.9; Fixes: RHBZ#1995390

* Sun Nov 07 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 0.1.8-5
- Drop logic for Fedora 32

* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.8-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild

* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 0.1.8-2
- Rebuilt for Python 3.10

* Tue Mar 30 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 0.1.8-1
- Initial package.

## END: Generated by rpmautospec