# Created by pyp2rpm-3.3.2
%global pypi_name changelog

Name:           python-%{pypi_name}
Version:        0.4.2
Release:        1%{?dist}
Summary:        Provides simple Sphinx markup to render changelog displays

License:        MIT
URL:            http://bitbucket.org/zzzeek/changelog
Source0:        https://files.pythonhosted.org/packages/source/c/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
BuildArch:      noarch
 
BuildRequires:  python3-devel
BuildRequires:  python3dist(setuptools)

%description
 Changelog A Sphinx < extension to generate changelog files.This is an
experimental, possibly-not-useful extension that's used by the SQLAlchemy <>_
project and related projects.Configuration A sample configuration in conf.py
looks like this:: extensions [ changelog extension 'changelog', your other
sphinx extensions ... ] section names - optional changelog_sections ["general",
"rendering",...

%package -n     python3-%{pypi_name}
Summary:        %{summary}
%{?python_provide:%python_provide python3-%{pypi_name}}
 
Requires:       python3dist(setuptools)
%description -n python3-%{pypi_name}
 Changelog A Sphinx < extension to generate changelog files.This is an
experimental, possibly-not-useful extension that's used by the SQLAlchemy <>_
project and related projects.Configuration A sample configuration in conf.py
looks like this:: extensions [ changelog extension 'changelog', your other
sphinx extensions ... ] section names - optional changelog_sections ["general",
"rendering",...


%prep
%autosetup -n %{pypi_name}-%{version}
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info

%build
%py3_build

%install
%py3_install

%files -n python3-%{pypi_name}
%license LICENSE
%doc README.rst
%{_bindir}/changelog
%{python3_sitelib}/%{pypi_name}
%{python3_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info

%changelog
* Thu Oct 18 2018 mockbuilder - 0.4.2-1
- Initial package.