# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}

%global crate rutabaga_gfx

Name:           rust-rutabaga_gfx
Version:        0.1.4
Release:        %autorelease
Summary:        Handling virtio-gpu protocols

License:        BSD-3-Clause
URL:            https://crates.io/crates/rutabaga_gfx
Source:         %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch:          rutabaga_gfx-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# This patch fixes the license and excluded unwanted *.py script from the
# crate.
Patch:          rutabaga_gfx-fix-metadata.diff

BuildRequires:  cargo-rpm-macros >= 24

# The spec fail to build for these architectures listed, because these
# architectures are not included in the conditional compilation attributes
# that use the stdio module. The stdio module is not declared for them in
# the crate file that uses it.
ExcludeArch: ppc64le s390x

%global _description %{expand:
Handling virtio-gpu protocols.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gfxstream-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gfxstream-devel %{_description}

This package contains library source intended for building other packages which
use the "gfxstream" feature of the "%{crate}" crate.

%files       -n %{name}+gfxstream-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+gfxstream_stub-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+gfxstream_stub-devel %{_description}

This package contains library source intended for building other packages which
use the "gfxstream_stub" feature of the "%{crate}" crate.

%files       -n %{name}+gfxstream_stub-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+minigbm-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+minigbm-devel %{_description}

This package contains library source intended for building other packages which
use the "minigbm" feature of the "%{crate}" crate.

%files       -n %{name}+minigbm-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+virgl_renderer-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+virgl_renderer-devel %{_description}

This package contains library source intended for building other packages which
use the "virgl_renderer" feature of the "%{crate}" crate.

%files       -n %{name}+virgl_renderer-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+vulkano-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+vulkano-devel %{_description}

This package contains library source intended for building other packages which
use the "vulkano" feature of the "%{crate}" crate.

%files       -n %{name}+vulkano-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+x-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+x-devel %{_description}

This package contains library source intended for building other packages which
use the "x" feature of the "%{crate}" crate.

%files       -n %{name}+x-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog