%global modulename emoji-regex

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-emoji-regex
Version:        6.5.1
Release:        1%{?dist}
Summary:        A regular expression to match all Emoji-only symbols as per the Unicode Standard.

License:        MIT
URL:            https://mths.be/emoji-regex
Source0:        https://registry.npmjs.org/emoji-regex/-/emoji-regex-6.5.1.tgz


BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch


Requires:       npmlib(%{modulename}) = %{version}

%description
A regular expression to match all Emoji-only symbols as per the Unicode Standard.

%package 6.5.1
Summary:        A regular expression to match all Emoji-only symbols as per the Unicode Standard.


%description 6.5.1
A regular expression to match all Emoji-only symbols as per the Unicode Standard.

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr es2015 %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr text.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
rm -rf node_modules && %{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc LICENSE-MIT.txt
%doc README.md
%{nodejs_dir}/%{modulename}

%files 6.5.1
%doc LICENSE-MIT.txt
%doc README.md
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Wed Nov 28 2018 npm2srpm <dshea@redhat.com> - 6.5.1-1
- Package automatically generated by npm2srpm