%global modulename is-cidr

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-is-cidr
Version:        2.0.7
Release:        1%{?dist}
Summary:        Check if a string is an IP address in CIDR notation

License:        BSD
URL:            https://github.com/silverwind/is-cidr#readme
Source0:        https://registry.npmjs.org/is-cidr/-/is-cidr-2.0.7.tgz


BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(cidr-regex) >= 2.0.10 with npmlib(cidr-regex) < 3.0.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
Check if a string is an IP address in CIDR notation

%package 2.0.7
Summary:        Check if a string is an IP address in CIDR notation


%description 2.0.7
Check if a string is an IP address in CIDR notation

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
rm -rf node_modules && %{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc README.md
%license LICENSE
%{nodejs_dir}/%{modulename}

%files 2.0.7
%doc README.md
%license LICENSE
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Fri Nov 16 2018 npm2srpm <dshea@redhat.com> - 2.0.7-1
- Package automatically generated by npm2srpm