%global modulename chalk

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-chalk
Version:        2.4.1
Release:        1%{?dist}
Summary:        Terminal string styling done right

License:        MIT
URL:            https://github.com/chalk/chalk#readme
Source0:        https://registry.npmjs.org/chalk/-/chalk-2.4.1.tgz


BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch

BuildRequires:  ((npmlib(ansi-styles) >= 3.2.1 with npmlib(ansi-styles) < 4.0.0))
BuildRequires:  ((npmlib(escape-string-regexp) >= 1.0.5 with npmlib(escape-string-regexp) < 2.0.0))
BuildRequires:  ((npmlib(supports-color) >= 5.3.0 with npmlib(supports-color) < 6.0.0))

Requires:       npmlib(%{modulename}) = %{version}

%description
Terminal string styling done right

%package 2.4.1
Summary:        Terminal string styling done right


%description 2.4.1
Terminal string styling done right

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js.flow %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr templates.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr types %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
rm -rf node_modules && %{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc readme.md
%license license
%{nodejs_dir}/%{modulename}

%files 2.4.1
%doc readme.md
%license license
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Fri Nov 16 2018 npm2srpm <dshea@redhat.com> - 2.4.1-1
- Package automatically generated by npm2srpm