%global modulename sliced

%global npmlib_dir %{npmlib_sitelib}
%global nodejs_dir %{nodejs_sitelib}

%define __requires_exclude_from ^%{npmlib_dir}/%{modulename}/%{version}/tests?/.*

Name:           npmlib-sliced
Version:        1.0.1
Release:        1%{?dist}
Summary:        A faster Node.js alternative to Array.prototype.slice.call(arguments)

License:        MIT
URL:            https://github.com/aheckmann/sliced#readme
Source0:        https://registry.npmjs.org/sliced/-/sliced-1.0.1.tgz



BuildRequires:  npmlib-packaging

BuildArch:      noarch
ExclusiveArch:  %{nodejs_arches} noarch


Requires:       npmlib(%{modulename}) = %{version}

%description
A faster Node.js alternative to Array.prototype.slice.call(arguments)

%package 1.0.1
Summary:        A faster Node.js alternative to Array.prototype.slice.call(arguments)


%description 1.0.1
A faster Node.js alternative to Array.prototype.slice.call(arguments)

%prep
%autosetup -p0 -n package

%build
# Nothing to build

%install
mkdir -p %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr index.js %{buildroot}%{npmlib_dir}/%{modulename}/%{version}
cp -pr package.json %{buildroot}%{npmlib_dir}/%{modulename}/%{version}



mkdir -p %{buildroot}%{nodejs_dir}
ln -s %{npmlib_dir}/%{modulename}/%{version} %{buildroot}/%{nodejs_dir}/%{modulename}

%{npmlib_symlink_deps}

%check
%{npmlib_symlink_deps} .
%{__nodejs} -e 'require("./")'

%files
%doc History.md
%doc README.md
%license LICENSE
%{nodejs_dir}/%{modulename}

%files 1.0.1
%doc History.md
%doc README.md
%license LICENSE
%{npmlib_dir}/%{modulename}/%{version}
%dir %{npmlib_dir}/%{modulename}/

%changelog
* Thu Dec 6 2018 npm2srpm <dshea@redhat.com> - 1.0.1-1
- Package automatically generated by npm2srpm