# Generated by go2rpm 1.8.2
%bcond_without check
%bcond_without bootstrap
%if %{with bootstrap}
%global debug_package %{nil}
%endif

# https://github.com/kubernetes/code-generator
%global goipath         k8s.io/code-generator
%global forgeurl        https://github.com/kubernetes/code-generator
Version:                1.26.0~rc.0
%global tag             kubernetes-1.26.0-rc.0
%global distprefix      %{nil}

%gometa

%global common_description %{expand:
Golang code-generators used to implement Kubernetes-style API types.}

%global golicenses      LICENSE
%global godocs          examples CONTRIBUTING.md README.md code-of-conduct.md

Name:           %{goname}
Release:        %autorelease
Summary:        Generators for kube-like API types

License:        BSD-3-Clause AND Apache-2.0
URL:            %{gourl}
Source:         %{gosource}

%description %{common_description}

%gopkg

%prep
%goprep

%if %{without bootstrap}
%generate_buildrequires
%go_generate_buildrequires
%endif

%if %{without bootstrap}
%build
for cmd in cmd/* ; do
  %gobuild -o %{gobuilddir}/bin/$(basename $cmd) %{goipath}/$cmd
done
%endif

%install
%gopkginstall
%if %{without bootstrap}
install -m 0755 -vd                     %{buildroot}%{_bindir}
install -m 0755 -vp %{gobuilddir}/bin/* %{buildroot}%{_bindir}/
%endif

%if %{without bootstrap}
%if %{with check}
%check
%gocheck
%endif
%endif

%if %{without bootstrap}
%files
%license LICENSE
%doc examples CONTRIBUTING.md README.md code-of-conduct.md
%{_bindir}/*
%endif

%gopkgfiles

%changelog
%autochangelog