# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}

%global crate v_frame

Name:           rust-v_frame
Version:        0.3.1
Release:        %autorelease
Summary:        Video Frame data structures, originally part of rav1e

License:        BSD-2-Clause
URL:            https://crates.io/crates/v_frame
Source:         %{crates_source}
# Manually created patch for downstream crate metadata changes
# * remove unused WASM support / wasm-bindgen dependency
# * remove hawktracer dependency
Patch:          v_frame-fix-metadata.diff
# * remove useless / no-op hawktracer macros
Patch:          0001-remove-unused-hawktracer-usage.patch

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Video Frame data structures, originally part of rav1e.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+serde-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde-devel %{_description}

This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.

%files       -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+serialize-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serialize-devel %{_description}

This package contains library source intended for building other packages which
use the "serialize" feature of the "%{crate}" crate.

%files       -n %{name}+serialize-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog