# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}

%global crate der-parser

Name:           rust-der-parser
Version:        10.0.0
Release:        %autorelease
Summary:        Parser/encoder for ASN.1 BER/DER data

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/der-parser
Source:         %{crates_source}

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Parser/encoder for ASN.1 BER/DER data.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/UPGRADING.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+as_bitvec-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+as_bitvec-devel %{_description}

This package contains library source intended for building other packages which
use the "as_bitvec" feature of the "%{crate}" crate.

%files       -n %{name}+as_bitvec-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+bigint-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+bigint-devel %{_description}

This package contains library source intended for building other packages which
use the "bigint" feature of the "%{crate}" crate.

%files       -n %{name}+bigint-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+bitvec-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+bitvec-devel %{_description}

This package contains library source intended for building other packages which
use the "bitvec" feature of the "%{crate}" crate.

%files       -n %{name}+bitvec-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+cookie-factory-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+cookie-factory-devel %{_description}

This package contains library source intended for building other packages which
use the "cookie-factory" feature of the "%{crate}" crate.

%files       -n %{name}+cookie-factory-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+num-bigint-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+num-bigint-devel %{_description}

This package contains library source intended for building other packages which
use the "num-bigint" feature of the "%{crate}" crate.

%files       -n %{name}+num-bigint-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+serialize-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serialize-devel %{_description}

This package contains library source intended for building other packages which
use the "serialize" feature of the "%{crate}" crate.

%files       -n %{name}+serialize-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+std-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+std-devel %{_description}

This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.

%files       -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+unstable-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+unstable-devel %{_description}

This package contains library source intended for building other packages which
use the "unstable" feature of the "%{crate}" crate.

%files       -n %{name}+unstable-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog