# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}

%global crate qemu-display

Name:           rust-qemu-display
Version:        0.1.3
Release:        %autorelease
Summary:        Helper library to communicate with qemu -display dbus

License:        MIT
URL:            https://crates.io/crates/qemu-display
Source:         %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch:          qemu-display-fix-metadata-auto.diff

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Helper library to communicate with qemu -display dbus.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+qmp-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+qmp-devel %{_description}

This package contains library source intended for building other packages which
use the "qmp" feature of the "%{crate}" crate.

%files       -n %{name}+qmp-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif

%changelog
%autochangelog